failed to install API with pip

I can not seem to install the metawear API with pip as reported here. Does anyone has the similar issue? I am using Python 3.8 with Arch linux system. I have bought 5 units and I am stuck. Any help is greatly appreciated!

Comments

  • edited December 2020

    I cannot get my pip3 install metawear to run either. There's two things in the stack trace that seem to be the issues, but I'm no closer to fixing them than I was a week ago.

    g++: error: unrecognized command line option ‘-marm’; did you mean ‘-fasm’? Makefile:84: recipe for target 'build/arm/release/src/warble/cpp/lib.o' failed make: *** [build/arm/release/src/warble/cpp/lib.o] Error 1 make: *** Waiting for unfinished jobs.... checking for g++... g++ checking whether the C++ compiler works... no configure: error: in `/tmp/pip-build-y0n38vz5/warble/clibs/warble/deps/libblepp': configure: error: C++ compiler cannot create executables See `config.log' for more details
    I'm assuming the -marm and -fasm issue is related to the second error.

    I got a little bit of help from someone referencing the second error with the C++ compiler that I may have specified the wrong build architecture somewhere, but I'm using a clean install of Ubuntu and having the same issue as I was.

    Any help is appreciated.

    Here is a pastebin with the full log, although the rest of it doesn't seem to have anything particularly useful.

  • edited January 3

    I removed -marm from the latest SDK build.
    I am in the process of updating this on the Python/Warble side. This should be done this week.
    Are you using arm64?

Sign In or Register to comment.