unable to install metawear on raspberry pi zero w

I am trying to use raspberry pi zero w to connect MMRL. The OS on the pi is Raspbian lite. the python version is 3.6.5. And it stuck while running setup.py install for warble.

output:
sudo pip install metawear
WARNING: Value for scheme.headers does not match. Please report this to https://github.com/pypa/pip/issues/9617
distutils: /usr/local/include/python3.6m/UNKNOWN
sysconfig: /usr/local/include/python3.6m
WARNING: Additional context:
user = False
home = None
root = None
prefix = None
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting metawear
Using cached https://www.piwheels.org/simple/metawear/metawear-1.0.2-py3-none-any.whl (242 kB)
Collecting warble<2.0,>=1.1
Using cached warble-1.2.6.tar.gz (1.6 MB)
Collecting requests
Using cached https://www.piwheels.org/simple/requests/requests-2.25.1-py2.py3-none-any.whl (61 kB)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /usr/local/lib/python3.6/site-packages (from requests->metawear) (1.26.4)
Requirement already satisfied: chardet<5,>=3.0.2 in /usr/local/lib/python3.6/site-packages (from requests->metawear) (4.0.0)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.6/site-packages (from requests->metawear) (2020.12.5)
Requirement already satisfied: idna<3,>=2.5 in /usr/local/lib/python3.6/site-packages (from requests->metawear) (2.10)
Using legacy 'setup.py install' for warble, since package 'wheel' is not installed.
Installing collected packages: warble, requests, metawear
Running setup.py install for warble ... /

Comments

  • Try to install warble on its own first.

  • It says you don't have bluetooth installed.
    That means you didn't follow the pre-requisite and install dependencies first. Please read our tutorials.

  • Now it just stuck here

  • edited April 28

    I did run
    sudo apt install bluetooth pi-bluetooth bluez blueman bluez-utils
    but bluez-utils is not found, it seems that bluez-utils has been removed and cannot be download
    But it still don't work so I run
    sudo apt-get install libbluetooth-dev
    Now it just stuck there

  • I think the problem could be the pi ran out of RAM
    Can I cross-compile SDK-CPP for it?

  • edited April 28

    I DO NOT recommend the Pi0. It just isn't powerful enough. Our stuff barely works/compiles/runs on Pi3 and Pi4 (they are just very weak/cheap computers). If you can, I recommend something like an Intel NUC running Ubuntu. But a Pi3 or 4 is still fine.
    You should be able to cross compile.

Sign In or Register to comment.