Timestamp Problems

edited June 4 in General

Dear community,

When grouping 3 sensors together using Euler recodings at 100Hz on MetaBase App (iPhone), 1 of the 3 sensors frequently produces a wrong timestamp for the first ~10-20s + incorrect data. The data during this time appears frozen, and repeats the same incorrect data until the time where it switches timestamps. After the "switch", the sensor will begin delivering the correct timestamp alongside the other 2 working sensors and generate clean data, but it's Elapsed Time column is very wrong. This timestamp problem occurs when grouping 2-3 sensors together, but does not only occur in 1 specific sensor - the timestamp problem will change between the 3 sensors throughout multiple recordings. We have 4 sensors, and have swapped out which 3 sensors are grouped together and still get the same problem with our incorrect recordings. Last, when I discover which sensor has provided the false timestamp in the previous group recording, I have isolated it and run an independent test and everything works normally. We are using the sensors to measure movement along the vertical axis (i.e. body turns left and right) in a controlled office environment.

Figure 1. is a screen shot of the diagnostics screen from one of our sensors.

Figure 2. demonstrates the exact moment where the timestamp switches from the false to correct timestamp.

Excel spreadsheet "sensor 3" demonstrates the problem at line 1346.
Excel spreadsheet "metawear" demonstrates the problem at row 3506.

Is there a solution to this problem or can anyone identify why it may be occurring and how to handle it?

Thanks,
Adam

Comments

  • edited June 4

    Hey @Adam_B
    So to replicate I just need to group 3 sensors in the MetaBase App and have them stream or log sensor fusion? Can you send me full replicable steps so I can reproduce this on my side.
    Also was this the iOS and Android MetaBase App?
    Stream or Log?
    How long should i do it for to get the same behavior?

  • Hi Laura,
    We group 3 sensors in iOS MetaBase App, "data logging", "Euler Angles". We record for minimum 5 minutes, maximum 12. But there is no pattern between length of recording time and whether we encounter this problem. We have not tried recording <5 minutes. We are also rotating our sensors along the vertical axis (i.e. head movements left and right) as we are interested in Yaw.

    We have not tried to do this with Android phone. However, we have also attempted to download the app on other colleagues' iOS phones and encounter the same problem.

    I look forward to hearing if you can replicate the problem or help identify a possible solution.

    Kind regards,
    Adam.

  • Hi @Laura,

    Have you found a potential solution?

    Kind regards,
    Adam

  • Still working on it.

Sign In or Register to comment.