How can resolve LoadError - dlopen(/Users/…/lib/ffi_c.bundle, 9)?

Hi, I'm an undergraduate student doing research using MMS+.

Now our teamates are working on swift api tutorial. However, when we type "pod install" command to the shell, the following error occurs. [LoadError - dlopen(/Users/…/lib/ffi_c.bundle, 9): Linrary not loaded: /usr/local/opt/ruby/lib/libruby.2.7.dylib]. The error occurs only when the line "pod "MetaWear", :subspecs => ['UI', 'AsyncUtils', 'Mocks', 'DFU']" is added to the Pod file. How can we resolve it? We're doing this on macOS.

Comments

  • edited July 7

    don't do
    pod MetaWear, :subspecs => ['UI', 'AsyncUtils', 'Mocks', 'DFU']
    do
    pod MetaWear
    basically, remove the subspecs part of the line.

Sign In or Register to comment.