not able to stream data from MMS device.

I am not able to stream data for the new MMS device. Any help would be appreciated.


  • @Anuroop

    Can you provide more details about what led up to this problem?

    For example, which app(s) are you using to stream data (or is the code you've written to do so)? Have you tried factory resetting the device? (Sometimes BLE communications errors might cause bad state.) Are you able to use MetaBase to share diagnostics info?


  • I am writing my own code using the apis provided. The datastream functionality mentioned in the tutorials does not work for me. I have tried resetting the device.

  • Also, for the code :

    var device: MetaWear!
    self.device.flashLED(color: .green, intensity: 1.0, _repeat: 3)

    I am receiving the following the error :
    Value of type 'MetaWear' has no member 'flashLED'

  • @Anuroop,

    Can you link to this code in a repo or can you make a gist including anything MetaWear related?

    If you're using the Cocoapods/Bolts based SDK, the MetaWear class doesn't have a function flashLED. An example of how to drive the led is in this MetaWear app sample code.

Sign In or Register to comment.