Senor does not give data and disconnects

Sensor Details:
Model - MetaMotionRL
Model Number - 5
Firmware - 1.7.3
Hardware - 0.5
Serial Number - 0628A7

Phone Details:
Model - OnePlus 7 Pro
Bluetooth - 5.0

Computer Details:
Bluetooth - 4.0

Sensor not connecting when placed within range
1. There's still a problem of sensor not staying connected when the distance is 10/15 feet, it only connects when it is just placed in front of BLE dongle (TP LINK dongle Bluetooth 4.0) and if we connect it first and then take it away the data stops coming.
2. If we try to initialize the sensor at a distance of 10/15 feet, it does not connect to the system and throws an exception. I have also tried another sensor but it's the same problem.
3. I have tried interfacing it in both Python and C#, and experiencing the same problems. It only stays connected with Raspberry Pi. I have also updated the sensors to the latest firmware version 1.7.3, but the same problems still exist.
4. I also tried it on the MetaBase app but the connection problem still exists, and if the sensor is placed just above the phone (on its screen) it only shows 4 signals instead of 5.
5. We have only used the mbientlab API in windows, and the problem still exists. Could you please provide help as soon as possible.

Thanks for your quick help, we really need it!


  • Also, when the sensor is enclosed in the palm the signal is lost within 3 feet. And it doesn't even show as discoverable in Phone as well as windows. I even tried Increasing the power through Python script but it was of no use. Below is the code for that
    device = MetaWear(address) device.connect() libmetawear.mbl_mw_settings_set_tx_power(device.board, 4)

Sign In or Register to comment.