Faulty MetaWear R Battery - Zero Percent 0%

I have MetaWear Rs, 2 from the Kickstarter campaign.
All of them work perfectly except for one(of the 10 new ones) which constantly reports that it has 0% battery even if it's charging. 
I noticed this was the case both before and after updating it's firmware. I have tried letting the battery fully waste and recharging it for a long period of time. I have also tried using your older and newer app as well as my own which uses your Android SDK, all of these result in the battery being 0%. These apps as well as my own report the battery level correctly for all other devices. The board works fine and stays charged for what seems to be around the same time as the other boards, but just reports it's battery is zero.

I have also noticed with the same faulty board, if you press the button, the board with become unresponsive and you will have to disconnect, wait and try to reconnect. This happens almost all the times with it occasionally allowing one or two presses before it stops working. Sometimes this will cause it to enter "MetaBoot" mode. Once it finishes MetaBoot, the 0 battery level issue persists.

To reiterate:
- I did update the firmware and app. It said 0% both before and after these updates.

- Even when the device is connected to a micro USB it still reads 0. When running on only the battery it works just like the others, but reports that the battery is 0.

- I understand it can quickly go to zero but for this device, unlike the other 11 devices I have, it is constantly at 0% and never any other reading. 

- Pressing the button causes the devices to freeze and then occasionally enter MetaBoot mode.

I've attached some images:
This is what is always shown for only this device
This is what happened after the button was pressed and it froze


  • Shoot a message to hello@mbientlab.com .  It sounds like you have a defective battery and the team should be able to help get that fixed for you.
  • Hi @lgleasain
    That's what I initially did and I was advised me to post here
  • Hrm, yes this definitely sounds like a defective battery / board.  Reply in your email with your order # and that the final verdict is the faulty battery/board so we can get it replaced.
  • @cianmce  Thanks for posting here first.  Just so that you know what is happening,  a lot of people have been sending e-mails to the team with questions on things that would benefit the entire community,  so they are starting to direct people to the forums first.
This discussion has been closed.