"Error: Error on Receive Firmware Image. Message: Invalid Response"

Received my C module today.  Using the latest iOS app.  Did a firmware update and got the above error message.  It went into MetaBoot, and when I try to recover it, I still get the same message.  I hit "Okay" and the message pops up 5 more times.  I tried deleting and reinstalling the iOS app, but that didn't solve the issue.

Any way to recover from this?


  • The new batch C boards require a different DFU process; we are updating the apps to accommodate the change.  You can try to reload the firmware using the Nordic Master Control Panel app with this zip file.  
  • Did you mean the nRF Toolbox app?  The master control panel app did not have a way to perform DFU.
  • They both do, the master control panel app only exposes the DFU option if the board is advertising in bootloader mode
  • Ok, that worked for me.  I was able to recover, although the buzzer and/or speaker don't seem to be working on this rev of hardware, but that's a separate issue.
  • I think I screwed up.

    I got my CPRO today and started playing around with it.  It seems great!  I kept trying all of the options, and I tried one I probably shouldn't have.  When I checked for updated firmware, it said it was already up-to-date.  Well...I of course hit update.  Following that, I got the error referenced in the title of this thread.  I can see it under MetaBoot Mode, but I keep getting the above error (perhaps as a result of the app using a difference DFU process?).

    Per the instructions above, I tried to update the firmware with Nordic Master Control Panel.  I just can't figure out how I can put the firmware on.  There doesn't seem to be any options obvious to me.


  • edited June 2016
    There is a DFU button next to the "Disconnect" button to open the DFU popup.  Choose the zip file option (first option) and use the zip file linked in my earlier post.

    You can also use the nRF Toolbox app to perform the DFU.
  • Thanks!  I couldn't get it to work with Nordic Master Control Panel, but I did get it to work with nRF.  All is well!

This discussion has been closed.