new board update issue / app store version

I’m having trouble connecting to a bunch of new MetaWear R boards. Through the MetaWear iOS app, v 2.11 (on iOS 10.1), the boards show up in the initial list, but attempting to connect to them to gives the error:

“Disconnect requested while a connection was in progress. Please try connection again."

This is only on brand-new boards that have not been connected before. Any boards I have already connected to in the past / updated firmware on / etc work fine.

I tried a few other iOS devices, including one which I wiped the entire device and started from scratch; the problem still occurred. 

Then I tried using various versions of the metawear sample app from github.

- the Oct 11 / 7d636e7 version worked great

- the Oct 12 / 539976b version exhibited the same issue as the App store version.

Is anyone else seeing this issue?


  • ...and it's fixed in 2.11.1  

  • No Problem!

    Note this bug exists in version 2.7.3 of the SDK, and will be fixed in the 2.7.4 release scheduled shortly.

This discussion has been closed.