Metawear app on iOS won't connect, but Android does

I have a Metawear C on firmware 1.2.1.  Yesterday was the first day in a while I've used it.  On iOS (I've tried my 5s which is 10.1.1 and my 4s which is 9.3.5) Metawear app, when I try to connect it simply bounces between connection state "Discovery" and "Disconnected" a few times then shows a dialog "The connection has timed out unexpectedly".  The last time I used it before yesterday (don't remember how long ago, but it's been a while) it worked fine.

On Android I don't have this problem.  I'm able to connect to it.  However, I'm NOT able to update the firmware via Android.  It stays at 0% for a while then fails and says "Upload failed: DFU process failed" in the notification bar.

I have the latest Metawear app on both platforms.  Anyone else having this problem?


  • Try putting the board in MetaBoot mode (press the button then power up the board) then reconnect to the either app.  Once connected, attempt a firmware update.
  • Eric, thanks for the suggestion, I finally got it working.  For the benefit of anyone else that may read this later on, here's what happened.

    I first tried this with the Android app.  For some reason it would still fail during the firmware update due to a "GATT CONN TIMEOUT" (this briefly shows in a snackbar at the bottom).

    iOS is the one that finally worked for me.  I basically had to get the app ready and in MetaBoot mode, then power up the board in metaboot mode.  AS SOON AS I SAW IT SCANNED, I had to tap on it and it started the firmware update.  It took a good 10-15 seconds before I saw the progress bar start to move, but it finally did and completed successfully.

    I think the timing of the firmware update was key.  On Android there are a couple dialogs you have to dismiss and then you manually have to hit the "Update Firmware" button.  This takes time and apparently you miss your window of opportunity (unless maybe you're much faster than me).  On iOS, it has no dialogs and automatically starts the update for you, so it happens much faster.
This discussion has been closed.