MetaBase download data


I have several Motion R, firmware 1.3.3, hardware 0.1, model number 5.

I use them to log data.

I tried to use MetaBase app on PC Windows 10 x64, i7-3770, 16 Gb RAM. 
First I config 4 Motion R for start logging 50 Hz accelerometer and gyroscope. After 15 min of logging I capture them. The data starts downloading. 1st, 2nd, 3rd devices succesfully ended the download, but the downloading time was 1 hour (!) for each. This download time is very strange. Sometimes data is downloads as quickly as it was recorded, especially for very short records - for example for 30 seconds of logging the data downloading time is about 30 s. But when log time is greater than some threshold download time became the maximum - about 1 hour. It seems like it is the time of full board memory download (but I don't need the full memory, I need only the data I just recorded for 15 min). In some experiments I got the approximate board memory value of 36 Mb.

Ok, the data from 3 devices is downloaded. But when it starts to download the data from 4th device, the app rises an error (without any notification) and closes automatically. I open MetaBase again and see that the data from first 3 devices is lost - I cannot download it again. At least, in capture list I see the 4th device. When I start downloading its data, the app closes again. The same result I get every time since then. 

So, I lost the data, and I can't use the 4th Motion R on this PC anymore. I tried to reset the device, I tried to update the firmware, I tried to reinstall MetaBase on PC, nothing works, the 4th device is still in capture mode and still cant be captured due to some error.

First problem: data download time ambiguously depends on logging time and usually this time is too long.
Second problem: I lost the data from 3 boards.
Third problem: I can't use 4th board on this PC anymore (at least, I can use it with my other devices on Android)

And some other times I got another problem:
Fourth problem: The download data is not about my recent logging experiment. It is about one week before.

I also have these problems also on my Samsung Galaxy S III GT-I9300 running Android 4.3 and on .

What am I doing wrong? What Can I do to escape these issues? How can I make results of my experiments stable and safe? 
Which apps on which platforms are stable and safe?


    1. A full download of the flash memory should only take about 35-40 min, which is to be expected as Bluetooth LE has a much lower bandwidth than classic Bluetooth or WiFi Direct.  An hour is pretty 
    2. The Windows MetaHub app writes data to the user's "Downloads" directory, search that directory for a "MetaHub" folder
    3. Board information is stored in the user's "AppData" folder.  Search for "MetaBase" and delete that folder to remove any persistent app data
    4. How often does this occur and is it only with the Windows app?
    Which of these issues are you experiencing on your Android devices and which Android devices are encountering these issues?  Does these same issues occur if you are only using 2 MetaMotion boards at a time?

    If you're on Android, try using a newer device with Android M or N.  On Windows, your luck will vary depending on which BT adapater & driver you have.  iOS generally has the best Bluetooth stack and has been the most stable ble platform for a while.

  • It occurs very often. I practically cannot do a planned experiment.

    Every platform apps have their own problems

    Windows MetaBase app. 
    I select configure, select the device, I press OK. Sometimes the app closes at this moment. Sometimes I can choose sensors and frequency and press OK. But then when I capture the data, I choose the board, press OK and the app closes. Every next try make the same result - app closes. I tried to delete "MbientLab.43351ABAF8FB0_afn0cdqbtq7je" folder in AppData. After that I just can't run the app. It does not open. I tried to reinstall it but the same problems occurs again.

    Android MetaBase app.
    I use Xiaomi Mi Note 3 running Android 5.0.2 and Samsung Galaxy S III GT-I9300 running Android 4.3
    These issues occur if I are using as 1, as 2 MetaMotion boards at a time.
    It seems like sometimes (often) some errors occurs during data logging and downloading. And the next time I try to log 10 seconds of data and download it, it downloads for too long (30 minutes on Xiaomi and 15 hours[?!] on Samsung) and the result data is from some past experiments. But after this huge time I usually have successful log and download 1 minute experiment (with 50 Hz acc + gyro, for example). So this huge time is like clearing the board from some errors in data storing. 
    Sometimes if I use several sensors (acc+gyro) and 2 boards at the same time, I got the error while config. It tells "Could not configure '4' to log all enabled sensors". ('4' is board name). And the other times there is no error. Screenshot:

    iOS MetaBase App.
    I use iPad Air 32Gb iOS 10.2
    Sometimes download data ends without errors, but when I try to share it with mail or Goggle Disk, I see only one file, instead of 4 files because the experiment was with 2 boards with 2 sensors on each (acc + gyro). So I lose my data.
    So how can I escape these issues even on the most stable platform?
  • Based on the stack traces from the various crashes with the Windows app, one of the crashes may be related to trying to acquire a path in the Downloads folder to store the data.  Try moving the existing MetaBase folder to another location and see if that solves the crash when attempting to capture data.  The other crashes I can't say for sure based on the stack trace alone and will have to look into it further.

    Regarding the Android app, the excessive download times you are reporting suggests that there could be active loggers on the board (such as ones added from the Windows app) when you use the Android app resulting in the same data being logged multiple times.  This potentially explains the aforementioned screen shot, which only occurs if the attempt to setup the logger times out.  Still, a 15hr download is way excessive and I'm not sure what could be going on with that Samsung device.

    I've let the iOS dev know to take a look at the iOS issues.
  • We are currently undergoing testing for an updated MetaBase iOS app to better handle the larger memory and longer download times of the MetaMotion R boards.  

    Thanks for the report, I will keep you updated.
This discussion has been closed.