cannot upload DFU and unit not responding to Android app

Hi, my unit can be detected and connected to using Android app but non of the application is working (not even the general information).
while trying to update the DFU the application shows "uploading" but the progress remain indefinitely at 0%

please advise.


  • @maalouf,

    You might need to power cycle the board and wait 60 seconds to ensure the board is no longer in boot mode.
    Try again using the Android App. If this does not work then you should try the iOS App.
  • no change. i already tried the 1 minute wait after a power up (saw that on the forum). I do not have access to an iOS (and not planning to buy any apple products any soon).

    I do suspect a hardware fault (faulty unit), however i will try to use the source code on github as soon as i can (available spare time) and report back. thanks for your reply.
  • @maalouf Have you tried a generic Bluetooth LE app such as the Nordic nRF master control panel:

    Might be worth it to see if that works and communicates with the board.

  • Got similar problem and solved.
    Put it here, in case someone bump to it.

    iPhone6 Plus iOS 8.1 -> Uploading stays at 0% and end, firmware not updated.
    iPhone5 iOS7 -> Okay, firmware upgrade confirmed.

    So, in my case it look like the iOS app not ready yet with iOS 8.1 (maybe 8.0 too).
    Try other options you have. Glad still keep those iPhone5.

  • What version of the ios app are you using?  The app was updated on the 28th to support iOS8.
  • The new iOS App version 1.1 fixes this problem.
    We have seen no issues with Android Apps.

    If your board is stuck in MetaBoot mode follow these steps:

    1.  Download Nordic Toolbox App from the App Store.
    2.  Download the latest MetaWear firmware hex file from this link:
    3.  Use the Nordic Toolbox App to load the file "firmware.hex" onto the MetaWear device that is stuck in "MetaBoot".
    4.  On success the device will start to advertise as "MetaWear" again.
  • @Eric
    iOS MetaWear app Version 1.1, Updated 2014/10/28. idk if there another factors, but my iPhone6 BLE work fine with other BLE devices.

    btw, I have a second board and look like its battery status is broken (always show 0). LED and button seems to be fine though. iOS app prevent the update (battery status 0, although its not). Use android this time, (compile source from git). The update process work fine. 
This discussion has been closed.