cannot install metawear

I use Ubuntu16.04 64bits in Vmware. and the python version=2.7.12
Firstly, I installed necessary dependencies of gattlib using command:

sudo apt-get install pkg-config
sudo apt-get install libboost-python-dev
sudo apt-get install libboost-thread-dev
sudo apt-get install libbluetooth-dev
sudo apt-get install libglib2.0-dev
sudo apt-get install python-dev
And these packages were successfully installed according to the command.

Then, I installed gattlib using command:
sudo pip install gattlib

Then, I install metawear package using command below:
sudo pip install metawear --process-dependency-links

but the command said "no matching distribution found for gattlib==0.2017002(from metawear)"

I know that because I install gattlib version 0.20150805,not the required 0.2017002.
But when I tried to install using command:
sudo pip install gattlib==0.2017002
the command said:"no matching distribution found for gattlib==0.2017002"

I also use command: sudo apt-get install update/upgrade ,but it seems not working.
and I cannot find version 0.2017002 online.

Could anyone tell me how to solve this problem .Thanks!

Comments

  • Don't install gattlib from pip; let the project's dependency links resolve the reference to the required gattlib version.

    Pip installs the package fine in my virtualenv with Python v2.7.14. If need be, clone the Python SDK repo and manually install with the setup.py file.

    python setup.py instll
    
Sign In or Register to comment.