Android SDK 3.4.0 - error during runtime

edited April 2018 in Android

I'm getting the following error during compile time, while using SDK 3.4.0:

-C:/Users/Playtech/Exsurgo Rehab Ltd/Exsurgo - Documents/Projects/Buzz Nudge/06 Software/Prototype Dev (Faisal)/ObserverApp
-com.android.builder.dexing.DexArchiveBuilderException: Failed to process C:\Users\Playtech.gradle\caches\transforms-1\files-1.1\metawear-3.4.0.aar\3a487c9cd06f053dad7c596ba6c54448\jars\classes.jar
-com.android.builder.dexing.DexArchiveBuilderException: Error while dexing.
-com.android.tools.r8.CompilationFailedException: Compilation failed to complete
-com.android.tools.r8.utils.AbortException
-Default interface methods are only supported starting with Android N (--min-api 24): com.mbientlab.metawear.ConfigEditorBase com.mbientlab.metawear.module.AccelerometerMma8452q.configure()

SDK 3.0.11 works fine. Any idea what's going on?

Using Samsung S8 and Android Studio 3.1.1.

Comments

Sign In or Register to comment.