"No files to send" after download

Hi Eric,
After logging quaternions and Euler angles in a MetamotionC with the MetaWear app from Android Store, I downloaded data using my Android phone. At the end of the download, when I selected "share data", I received the message "No files to send". Do you know why it appeared ? Normaly I did nothing wrong. Is there a way to find the data back ? They are very important for me. Right after, I tried a new time to download data as I saw a little red circle next to the sensor name. But this time, the download took only 1 sec and I recieved same error message "No files to send". After reseting the sensor, the Metamotion is now working fine.
Also, usally I am working with the windows 10 App with 2 MetaMotionsC (not at the same time). I am using an Android device since a few days because on the Windows app only one sensor appears for logging and streaming. It is always for the same one and also when it is disconected. I tried by reinstalling the app but the problem still occurs.


  • Files are saved locally in the public "Downloads" folder; check if there are any CSV files there.

    Try repairing the boards to your Win10 machine.

  • I found .csv files but not the one I need.
    For the windows app, it works now thanks.

  • Hi,

    We are experiencing the same issue using the MetaBase app together with MetaMotion C boards for data logging. This setup worked until a few days ago. Since then, we've been getting the error message "No files found" after downloading and no new files are created in the "Downloads" folder where the data was saved previously.

    We have both reinstalled the app and even done a factory reset on the phone but the problem persists and the app has both file access and location information permissions. The phone is a Huawei Honor 8 Lite but we can reproduce it on other phones as well (and as mentioned, download worked on the very same phone before).

    Any ideas?

  • @rolandh
    Odd, I have not encountered issues with creating CSV files unless there was no logged data to retrieve.

    Is your device properly functioning i.e., is it logging any data at all? Do you see a progress bar when downloading data or does it immediately show the share & sync buttons?

  • @Eric, yes, the devices work and there is data to be downloaded. The download itself works as usual: It shows the progress bar and takes the usual amount of time (several minutes as we are logging quite a lot).

    Does the app create a debug log somewhere?

  • The app sends exceptions to Firebase but there are no local logs.

    Check Logcat to see if any messages are displayed with the "metabase" tag.

  • Unfortunately, logcat doesn't show any error messages for metabase.

    However, I seem to have found a the cause of the problem (and a workaround): It seems that it has to do with the "com.mbientlab.metawear.metabase" folder in "Downloads". If the folder doesn't exist or you create it manually, the app's download function doesn't store the data there (and it seems like the folder is not created by the download functionality). However, if I first run a diagnostic on one of the sensors, the folder is created and after that, downloading seems to work fine.

This discussion has been closed.