Linear Acceleration Output Impacted by Change in Direction

We've been using MetaMotion R sensors since February. Linear Acceleration has been working consistently for us for the past few month. However, over the past week, we've started seeing drift and offset.

There are no changes to the environment where the data is sampled (e.g. no new equipment).

This is impacting multiple sensors, both with hardware version 2 and 3. All sensors are running 1.3.7 firmware.

In our experiment, the sensor is taped securely to the center of an individual's upper body. The individual walks in a straight line, turns around 180 degrees, then walk back to the starting point. This is done twice per sample. Individuals are not carrying phones, wearing pacemakers, or other electronic equipment.

Linear Acceleration data is logged to the flash, and read after the sampling is done.

Pervious Behavior

Current Behavior

It appears that Linear Acceleration mode is seeing impact from magnetometer as the person/sensor changes heading. In this case turning around 180. Please see Magnetometer & Raw Accelerometer z-axis graph below.

Figure-8 and random motion did not improve the behavior. We tried recharging the battery, soft reset, reapplying latest 1.3.7 firmware, none of those helped.

Changing from NDoF to IMUPlus mode showed some improvement, but still observing smaller drift/offset. (See below, AP = z-axis). This seems to suggest that magnetometer is impacting linear acceleration even in IMUPlus mode.

Subsequently, we've alter the code to use fusion.acceleration with NDoF mode. This configuration did not exhibiting drift/offset from the change in direction. Please see comparison chart below. (AP = z-axis)

We can reproduce this behavior using both our own custom app and MetaWear app on iOS.

I've recently ordered another batch of MetaMotion R. With a brand new and fully charged sensor with 1.3.7, I am seeing the following behavior with Linear Acceleration drift/offset increasing with data taken 3 minutes apart. This is taken with our own app.

I'd like to understand what's causing the sudden change in behavior, and if there are any solutions. Also, have you seen other reports of this behavior?



  • edited June 2018

    I'll forward this thread to the firmware dev.

  • Thanks Eric. Does it make sense to downgrade to 1.3.6 and retry?

  • @gjin said:
    Thanks Eric. Does it make sense to downgrade to 1.3.6 and retry?

    You can try but there isn't an sensor fusion code changes between the two versions.

  • I tried 1.3.6, and as expected, no change in behavior.

    I also noticed that the drift/offset is less dramatic when moving in North-South direction than East-West direction. Hopefully this is a helpful clue.

This discussion has been closed.