MetaBase Android App Stops Streaming After 30 minutes?

I am having an issue with using the MetaBase android app to stream data from my MetaMotion R device. After about 30 minutes of streaming to the phone, the data stops streaming. It will say that it is still streaming but the number of samples collected will be blank and after stopping the stream, the saved data will only be for about 30 minutes. I did not have an issue with the iPhone app, only the android app.

Comments

    • What Android device / OS are you using?
    • What sensors are you streaming and how fast?
    • Did the device simply lose connection?
    • Does this behavior consistently happen?
  • -Android devices model numbers: MotoE 2nd Gen, LGLS676 with Android OS: 5.1 and 6.0.1 respectively.
    -Sensor: MetaMotion R, streaming accelerometer at 200Hz and Gyro at 100Hz.
    -It seems like rather than losing connection it just stops streaming data. So it says it is still connected but the number of samples field goes blank and the data file ends after a specific amount of time.
    -We tried this 4-5 different times on the two different phones. We let it stream for 2 hours each time but each time it only kept data from the first 35 minutes. It seems like it is stopping streaming at around the same time every time. Note: This did not happen on the iPhone app. We were able to stream for 2 hours at the same rates with the iPhone app.

  • edited April 3

    Try using a device other than a Motorola device; I have never had good experiences with their BLE adapter / stack.

    i generally have had very good experiences with Samsung and Nexus devices, and even with a virtualized Android x86 machine.

  • edited April 5

    Alright so we tried out a Samsung S7. We are now having an issue with the device stopping streaming if you minimize the app. For some reason it seems that the app is timing out or something if put into the background. I even turned off power optimization for the metabase app and it still did this. It looks as though it stops streaming almost exactly 15 mins after minimizing the app. I just want to note again that this was not an issue on iPhone. You could minimize the app and run other apps and streaming would not be disrupted. Any suggestions?

  • It probably has something to do with Android pausing apps after a period of time in the background. There's nothing you can do about that, the app will need tweaking regarding how services are managed.

  • Eric, any idea a time frame for this bug to be fixed and a new release of the app? Having an app such as this set up as a background service seems pretty standard for something that you would want streaming information in the background. I'm assuming the app source code is unavailable?

  • This isn't really a "bug" in that the app behaves as expected within the context of an Android app's life cycle given it's specific configuration.

    MetaBase is undergoing an update anyways and we can look into modifying the behavior after the major updates are implemented. The next update will probably be ready within the month.

  • I would consider this a bug as it seems to be a performance over sight on the part of the developer. I would think that having an app that you want streaming in the background would be configured to continuously run as a background service...

  • Anyways, thank you for the help, please let me know when an update is available.

  • Thanks to all for their help as from their discussion I got the result and got my queries cleared up. Really thanks.!

  • Hello Eric, has there been a new update released to address the issue described in this thread?

  • @starlipernl said:
    Hello Eric, has there been a new update released to address the issue described in this thread?

    yes

  • Hello Eric, thank you for the help so far. It seems like the new app update has fixed the issue and the sensors now stream for multiple hours even when the phone is locked.

    However we are noticing one additional problem still: if we open other apps, the metabase app will stop streaming after 15 minutes or so. It seems that opening another app, stops the metabase app from running in the background after a certain amount of time. When I say that the app "stops" I mean that I get a pop up message saying "Metbase App Has Stopped". Please let me know what you think may be causing this.

Sign In or Register to comment.