MetaMotion R stops to work with MetaHub after upgrading firmware using MetaBase


I was using the latest version of the MetaBase app in a Samsung S8 to figure out the mac address of my sensors as well as the battery level of each. The app popped up a message to upgrade the firmware and I ended up upgrading it. The sensor had 80% of battery.
After that, I tried to connect this sensor to Metahub using the command line command and I'm getting the attached error.
We bought the sensors at the same date, so I believe that all of them came with the same firmware version. I'm saying that because the version 1.3.7 I obtained by using the diagnostic option of Metabase app to one sensor which has not been upgraded. So I believe that all sensors were with the firmware version 1.3.7. The sensor that I tried using with Metahub has now the version 1.4.1.
Other sensor with firmware version 1.3.7 is working perfectly with the Metahub though.

Three questions:
1) Are you going to correct this bug in the next image?
2) When a new image for the Metahub will be available?
3) Is the upgrade of sensors recommended at all??



    1. I do not have issues using MetaHub with firmware v1.4.1. Does the MetaBase app on you Samsung work with the board?
    2. Probably next month.
    3. Yes, you should always be using the newest firmware.
  • Yes, it does work, that's the weird part.
    The issue also randomly happens with other sensors as well.
    The Metahub asks to update the npm package, on and off. I have tried updating that some months ago and the Java scripts stopped working at all, so I had to ask a copy of the image to you guys to reset the system. Thus I don't believe it is an option.
    Is the error familiar to you at all, is there anything in my procedure that may cause an error with such message?

  • The update npm message comes from npm, it is not a MetaHub message. Regardless, I have not run into any issues when updating npm so I can't address your specific issue. Next time, record the commands you run and their output, and post errors you encounter as opposed to only reverting the image. We can't address these problems if we don't receive any details about them.

    Connection errors happen. When they do, make sure the Hub detects the board with a BLE scan and try to connect again. Sometimes, you may also need to reset the bt adapter.

This discussion has been closed.