ANCS demo fails to compile

There is a linker error compiling indicating that libPods-ANCS.a is missing
Please update the tarball so it compiles. 


  • Did you open the .workspace instead of the .xcodeproj?
    You need to open the entire project, not just the App or pods by themselves.
  • I open by double-clicking ANCS.xcworkspace, then Cmd-B to build which results in a linker fail.
    I would appreciate step by step instructions. 

  • Hi pbljung,

    Are you compiling for the simulator? Bluetooth does not work on the iOS simulator and must be run on a real iOS device.

  • Cool project but I can't get it to work

    Board works fine, successfully connected, leds flash etc.
    Successful compile and install on iphone (opened .workspace)
    Board successful connects to phone
    Added two contacts in the app
    Called phone, and got no response from board..

    Am I missing something?  Thanks for the help..

  • edited March 2015
    Did you set up an ANCS trigger? If so, can you tell me what kind of trigger you set up and maybe share some screenshots? I would like more details so I can help you debug.
  • Hey Laura thanks - I may be missing something, but I just ran the app, didn't modify the code at all.  When it was running on the iphone I added a contact, refreshed the screen so that it said 'Programming..."  then sent myself a text and called myself from another phone - and the metawear board led didn't light up..


  • Lauren,
    Do you know which MetaWear firmware version you are on and what type of phone you are using?
    What you are describing should work just fine.
    I would suggest to clear all your old notifications and test with something different like a text message. Let me know how that goes.
  • Laura tried, cleared all notifications, restarted phone, rebuilt apps - same results.  I also built your simple app that is supposed to connect with the board and flash the led - it loads and compiles fine, then when it runs all I get is a blank white screen.

    Me: iPhone 6+ IOS 8.2, plenty of memory

    Summary for three apps:

    MetaWear app works fine - connects easily, leds flash etc.
    ANCS app loads up, connects to the board, lets me add a contact - then nothing
    The Sample app boots up fine shows: 'MetaAPI' text, then goes to a full white screen and doesn't flash led

    I can't figure out how to attach screen shots to this email -  otherwise I'd send them along - 

    If you have anything else you could think that I might try - please send it along



  • Lauren,

    Which triggers did you use and test?
  • Laura, I really don't know what you mean by 'which triggers' - the app only asks for contact info for someone - so I added a contact - and then sent a text and called that phone - nothing happened.
  • edited March 2015

    One more thing, did you update to the latest firmware release?

    Can you test your triggers by leaving the App in the foreground (don't close the App). Let me know how that goes. 

    I just tested it on my phone and setup a trigger for Matt and it worked fine when he called me but didn't trigger when he texted me.
    A few seconds later, now it's working fine for any trigger from him (including texts).

    ANCS is very finicky, Apple doesn't guarantee all notifications. 
    One thing I would advise is to also CLEAR all your phone notifications from the menu before you play with the App.

  • Laura,

    I also have a same problem. it did not work at all.

    Does this work when Matt use Android phone?
  • does this work iOS 8.2?
  • ANCS is iOS only. It does not work with Android (It is the Apple Notification Center).
    I tried it using iOS 8.1 and 8.2 and it was fine for me.
    The trick is to try different triggers. Once it gets going then it will work consequently.
    Let me know how you are setting up the notifications so I can help you debug.
This discussion has been closed.