Haptic and air pump command


I'm working on a project using the metawear and I ran into an issue (misunderstanding?) with the Haptic circuit.
I'm trying to command a micro air pump working on 3DC-0,16A using the Haptic circuit. Few days ago it worked well but today, after the upgrade of the metawear, it didn't work anymore : I lost the power needed. I'm not sure it's related with the upgrade, what do you think?

Thanks in advance for your answer.


  • Helene can you give us a circuit diagram? How are you hooking up the air pump?
  • Hello Laura, 

    The air pump is hooked up to the HCD (pin 10) and the 3V pin (pin 11) on the MetaWear board.

  • Do you have any more details like part numbers?
  • About the pump I have this KPM12A-3C

    Is what your asking for?
  • I looked up the data sheet for the part KPM12A-3C:

    Rated Voltage 3 VDC 3 VDC
    Operating Voltage2.0-3.2 V2.0-3.2 V
    Rated Current<300 mA<460 mA

    Basically you should not hook up the 3V to pin 11 of the board; instead you should hook it up directly to the battery power. The board cannot give 300mA continuously, it is too much current.

    Try this setup: HCD (pin 10) and the 3V pin (BATTERY +).
  • edited April 2015
    A few things to watch out for. First make sure your board is still working; it might have been overloaded with the previous setup and no longer works.
    Second, it would be preferable to hook up some protective circuitry from the battery to the 3V pin instead of soldering it directly (regulator, diode...).
  • Thanks Laura!
    Very helpful.
This discussion has been closed.