No connection after firmware update


I got the board and could connect it with my iphone 4s. i could load the test program and flash the led in the different colors. nice! ;)

but then i clicked on the firmware update-button....nothing really happend and after a while i could not connect anymore to the board. it does not apear anymore in the "scanning for devices"..... the battery is still good and running. what could i do?

thank for the help.

greetings, till


  • subtill
    It can take up to 60 seconds for a checksum and board reset to occur once the firmware update is complete. During that time, the board will not advertise and will not be connectable.
    Please wait a few seconds after an update before attempting to reconnect to the board and let me know if you are still seeing issues.
  • Hi,

    I have a similar issue. After performing a firmware update the metawear iOS app no longer detects te board. BLExplr does detect the board but it appears as MetaBoot ins tread of MetaWear.

    Any ideas?

    Kind repards
  • It takes up to 60 seconds for MetaWear to return from MetaBoot mode depending on how large the new firmware file was. Just wait patiently and all will be well again!
  • @Laura, I have let the batery drain completely. After charging it back up the metawear is still in MetaBoot mode. It does not return to MetaWear status. Any Ideas?
  • It can take up to 60 seconds to return to the MetaWear mode from MetaBoot. Basically just let your board chill for a while, grab a beer or soda...then you can connect to your MetaWear again!
  • @Laura. No succes had a couple of beers but it's still in MetaBoot. ;-)  Is there a way to reinstall firmware in this mode?
  • edited October 2014
    Can you try to restart the iOS or Android App? Basically reinstall the App and see if MetaBoot or MetaWear is showing up. 
    Sometimes the App will successfully update the board. The board will get out of MetaBoot but the App will be showing something that is completely outdated (i.e showing MetaBoot instead of MetaWear). I sometimes reinstall my iOS MetaWear App after a firmware update because iOS8 has trouble identifying new Bluetooth Devices (this is a known issue).
  • same here no result after re-install

  • Hey paul,
    Can you email me at
    I want you to try to use the Nordic App to update the MetaWear board using a specific firmware file I will send you via email.

  • The new iOS App version 1.1 fixes this problem.

    If your board is stuck in MetaBoot mode follow these steps:

    1.  Download Nordic Toolbox App from the App Store.
    2.  Download the latest MetaWear firmware hex file from this link:
    3.  Use the Nordic Toolbox App to load the file "firmware.hex" onto the MetaWear device that is stuck in "MetaBoot".
    4.  On success the device will start to advertise as "MetaWear" again.
  • Hello everyone,
    I'm writing in this old post because i'm facing the same issue. 
    A metawear sensor is stuck in metaboot state after upgrade. I tried to flash the latest firmware ( ) with nRF app unsuccessfully.
    With nRF android APP I'm unable to select the device.
    With nRF iphone APP I'm able to upload the firmware ( selecting application ) but I've got a CRC error just after the upload.
    Any solution for this issue?


  • What board are you using?
    Is bith Android and ios metawear app repeatedly failing the update the board?
  • My board is a Metawear RG.
    Yes, it keep failing but with 2 different errors. 
    With Android I'm not able to select the board with the button "Select Device". With the iphone I get a CRC error. 
    Is that correct to select "Application" when the app asks "Select file type"?

  • I'm asking if the DFU repeatedly fails with the MetaWear app, not the Nordic Toolbox app.  The latest version nRF app doesn't work with our bootloader.  This thread is only appropriate if you have a version of the app from 2014.
  • I'm sorry, I misread your last post. 
    I tried to update the firmware via metawear android app. The update process completed but the sensor keep rebooting in metaboot. 
    I'll try with an iphone, maybe I'll be more lucky.
  • A few other users have reported similar issues and said updating with the iOS app fixed the bootloader issues.

  • Ok, I tried at office with an iPad. It worked. 

    Thank you so much
This discussion has been closed.