Can't connect to board

edited February 2016 in Hardware
I took out my RG after about a month of not using it. It used to work fine but now I can't connect to either the iOS sample app or Fitness Tracker app. I've updated to iOS9 and latest version of the apps (on both an iPhone 5 and 6); charged the board, turned phones off and on, bluetooth off and on, reset the board by holding down button while plugging into USB. I also took the board away from any other BLE devices to a secluded area. Nothing works. I've read on the board that perhaps I'm stuck in boot mode but I wanted to get opinions. Also if I need to update the firmware, any good tutorials on how to do that would be helpful please.


  • Does the board show up on other iOS Bluetooth LE apps?  The iOS app has a switch that can detect boards in bootloader mode.  Does enabling that show the board on the devices list?
  • No...I downloaded an app called LightBlue which scans for any nearby BLE peripherals and it didn't show up there. And by enabling the MetaBoot mode switch it does not show the board on the devices list either.
  • It's possible your battery is just plain dead.  Lithium ion batteries should be regularly charged and cannot sit on an empty charge for too long.
  • If it's plain dead, wouldn't plugging it into the USB allow it to be powered while plugged in at the very least?

    I'm also having an issue. I just received my RG today, and have so far not been able to get any BT scan to see it. Let alone the MetaWear App. I have tried the boot mode as well. I haven't tried the reset trick because I was hoping to not have to do any soldering before testing the board. To me it is DOA at this point.

    This does seem to be quite a common problem which tells me that MbientLab is having some trouble maintaining a consistent quality measure with their supplier or whomever is actually doing the manufacturing/assembly.



  • I did remove the glue that was providing extra support to the power wires coming from the battery, there doesn't appear to be any shorts or additional "connections" being made that shouldn't be. The connection does seem to be solid.


  • edited March 2016

    We don't have any issues with thousands of devices in the field today; you are the only one having issues currently which leads me to believe it is more likely human error.

    Can you do some proper debug and give us some feedback.

    1) Do you have a meter / DMM that can read the output Voltage of the battery? Can you report the battery voltage to us?
    2) Did you leave the battery unplugged so long that it killed the lithium battery? Lithium batteries die when over-discharged, you can read more about it on this great website:
    3) Does the MetaWear work when plugged in?
    4) What firmware and App version / release / hardware are you using?

    If you don't properly describe your problem, it will be difficult for us to help you resolve it.

    We replace DOA boards (but not damaged boards) so you can email us to inquire about the exchange/return process.

  • Ballistic,
    If you have access to an engineer or technician (or hardware knowledgeable friend), please consult them immediately.
This discussion has been closed.