Metawear C and Neopixels

Does Metawear C work with Neopixels? I tried, following the examples with Metawear R, without success.


  • Yes but the CR2032 battery alone is not enough to power the strand.  You will need an additional power source for the NeoPixel strand.
  • I was powering the  (10 led) strand separately. I used the neopixel IOS app (MetaWear CESSHOW) in the latest Obj-C and isolated the code to just light up one led. To isolate errors, I connected the same strand to the same power and an arduino running fast led, and it ran perfectly.

    I put a breakpoint in Obj-C to make sure the code was executing.

  • edited August 2016
    That project hasn't been updated in 1.5 years.  You should try using the MetaWear app to control the NeoPixel strand.

    Just so everything is clear, which metawear pin did you connect the data wire to and did you properly ground the strand?
  • I used pin 0 on the metaWear and connected the Metawear Ground to the ground of the external power source used for the strand. I verified that it was really pin 0 by using the metawear app to switch the pin 0.

    What code should I add where to the metawear app?

  • The MetaWear app already has a section for NeoPixels; you can use that to test strand since it looks like you have everything correctly connected.
  • I ran the latest version of the MetaWear app (deployed from xCode) and upgraded the MW firmware (yesterday) but it did not work. I did not change anything in the app. To find the issue I:
    - made sure the neopixel was getting 5v.
    - connected the MW to 3 v power supply to make sure low battery was not an issue.
    - tried all combinations of settings in the app (Fast/slow etc).
    - restored the MW to  factory settings.

    All other functions on the app seems to work fine (blinking leds etc).

    I will check all connections once again. 
  • I did the connections again (the same way as before) and now it works. Probably a glitch.
    Thanks for your support.
This discussion has been closed.