I do not understand how logging works

So if i call the Start_Logging function the data is logged unto the board...When is this log deleted from the board?  When i call stop logging or when i remove the logger?

How exactly do i get the log from the board? How will the log data be represented? 

I read this page  but it wasn't much help. I am coding for windows universal apps. 


  • The firmware manages all of the log data, you do not need to worry about when log data is deleted.

    Read the section about the MblMwDataLogger object.
  • edited August 2016
    I did. But i do not understand how to retrieve the logs... I am trying to log acceleration data on the board. Like, where is the data stored and what format is it in (after it is downloaded).
  • You retrieve the logs by calling mbl_mw_logging_download as outlined in the Downloading Data section.  Logged data is handled in the same way as streamed data.  If you not yet tried data streaming, you should first try streaming before doing logging.
  • Thank you, i got it downloading, now the problem is that, i dont think it is downloading all of the log...

    When i run this code to download the log:

      hand = new LogDownloadHandler();
                hand.receivedProgressUpdate = new FnUintUint((uint nEntries, uint totalEntries) =>
                  System.Diagnostics.Debug.WriteLine("Progress: Num of entries: "+nEntries +" total entries:"+totalEntries);
                   if ( nEntries == 0)
                       System.Diagnostics.Debug.WriteLine("Downoad Complete!");


                hand.receivedUnknownEntry = new FnUbyteLongByteArray((byte id, long epoch, IntPtr value , byte length  ) =>
                    System.Diagnostics.Debug.WriteLine("Received unknown  entry!");
                mbl_mw_logging_download(cppBoard[0], 10, ref hand);

     It downloads them, and then it stops downloading , i dont even get the "Download Complete" text.. It just stops. Here is the Debug output.


    I dont even think the numbers are right, how can there be more num of entries than there are total entries?

  • edited October 2016
    Update to the latest firmware (v1.2.4) and try the download again.  It sounds like you are using an older firmware build.

    If you are unable to update the firmware, you can instead mask out the upper 2 bytes of nEntries before using it in the callback function.
This discussion has been closed.