Couldn't get the android app to work with Nexus 5

Just a quick tip for y'all... I had a heck of a time using my Nexus 5... wasn't even able to upload new firmware.

But! I tried on two other phones and it worked no problemmo. Got the LEDs to work as confirmation that everything is more or less fine. 

So... if you're struggling getting basic functionality, just try a different phone. 



  • That's odd the Nexus 5 would give you so much trouble; it runs Android 4.4 and has Bluetooth 4.0 so I don't see why the app wouldn't work on your phone.  The only thing I can think of is Android 4.4 regressing with Bluetooth support as all of the Android development is done on Android 4.3.
  • Same problem for me. I have nexus 5 running Android 6.0.
    Metawear app doesn't see any device, even if I can see the sensor in the Android's bluetooth settings.
    I tried with an iPhone 5 and I can connect properly.

    Any idea?
  • It could be that there is a bug with the radio waking up.  Try turning off bluetooth and then turning it back on.  I have a stock Nexus 5 on 6.0 and it seems like ti does sometimes get a little flaky,  but this always fixes it for me.
  • Unfortunately I already tried. The strange thing is how come it is possible to see Metawear within BT devices and not inside the Apps...
  • edited February 2016
    You are using the latest version of the app I presume?  Android 6.0 now requires location permissions to do scans in the background.  If you selected "No" when prompted by the app, then you will not see any devices from the scan.
  • I tried updating Android to 6.0.1. Nothing new under the sun: I see the device under BT, i can connect to it but the "select device" screen in the metawear app still stays empty. I checked the app authorizations and it has it...
    I wish I could connect to it at least with my laptop 
  • Problem solved: I found that I need to have the geolocalization function of the phone turned on. I don't remember reading it on other posts :)
This discussion has been closed.