Sensor cannot be found via bluetooth scan

edited November 2016 in Hardware
One of our MetaWear C sensors was working perfectly for at least 5 weeks. However, a few days ago we cannot detect the sensor anymore. We used the sensor as a pendant and has a plastic case to keep out water. The sensor was not dropped nor smashed.

We tried to replace the battery as well as using different phones to scan the environment, the sensor didn't show up. It didn't show up when we scan the environment with the Nordic app. And the new battery showed fast voltage drop.

How can we deal with this sensor? We might need your help to identify the issue.

Thank you!


  • We've also tried to set the sensor in MetaBoot mode by pressing the switch for long. However, that doesn't work.
  • Given that you mentioned keeping out water, did you submerge  the enclosure in water?  What exactly was the board subjected to over the previous 5 weeks?
  • @Eric, the sensor was worn as a pendant. We only used the sensor to collect accelerations and temperature. I mentioned the case to give you information that the issue is not related to water damage. Sorry for the confusion.
  • Please email us directly (CC me) and attach pictures of the board.  We may need to take a look at board with our equipment if we can't discern the issue(s) from the images.
  • @Eric, I've got the new sensor. Could you keep me posted if your team figure out what was the issue? 
    BTW, what's the difference between hardware design r0.3 and r0.2?
  • edited November 2016
    r0.3 uses a newer SDK for the SOC
  • @Eric,

    We've found another issue. Some of the Metawear C sensors cannot be found by both android & iOS device even we replaced the battery. They were running firmware v 1.2.1. 

    However, when I pressed the switch for 2 seconds, they can be identified as MetaBoot device by iOS. Only when the iOS MetaWear app started to upgrade the firmware, the sensor showed up as a MetaBoot device on Android. And the issue was resolved by that firmware update.

    I wonder what was the issue when we were not able to find the device. 
This discussion has been closed.