MetaWear Motion iOS Quaternion Reading Issue

edited February 2017 in iOS
Hi I'm just getting started using MetaWear Motion and I've hit a snag.

I've managed to get connected to a board and quaternions streaming to an app on Android, but I can't get the code from the iOS documentation page to work

Here's the code I'm trying

[[_device connectAsync] success:^(MBLMetaWear * _Nonnull result) {
if(_device.sensorFusion != NULL)

[_device.sensorFusion.quaternion startNotificationWithHandlerAsync]:^(MBLQuaternionData * obj, NSError error)
NSLog(@%@", obj);

I get the "Connected" in the console, and I'm able to trigger the LED to blink and turn off and such with some other code, but the quat handler block never seems to get called.

I've checked several of the iOS MetaWear example apps provided but everything is done in Swift, and they don't seem to have any extra steps anyway.

Is there something obvious I'm missing?


  • edited February 2017
    Well follow up, I tried it in Swift and it worked, so I just converted my project.
This discussion has been closed.