BUG in Firmware Release 0.8.0 - FIXED in 0.8.6 and new iOS APP

edited November 2014 in Firmware
There is a known bug in firmware release 0.8.0.
We are working on a fix; it is expected this week.
In the meantime, please do not update your MetaWear boards.
Thank you and apologies for the inconvieninece.


  • edited November 2014
    Whats the problem?!
  • schartiph,
    In a few cases, some MetaWears stop advertising with the new firmware release. As such, they are not connectable and are essentially briked.
  • Thats exactly my problem :(
  • We have fixed this issue now and we are testing the new firmware release (0.8.2).
    Expect a release tonight or tomorrow morning.
  • Briked:
    Do you mean MetaBoot (switch + USB power on) is not working so you can not reload a firmware using Nordic tools DFU?
  • edited November 2014
    When the unit is briked it does not advertise at all including MetaBoot or MetaWear advertisements. This means you can't connect to it at all using the Nordic Tools or the MetaWear App.

    Some folks have been able to get their units "unbriked" by shorting the reset pin and holding down the push button (this process is described in this post: http://community.mbientlab.com/discussion/comment/461/#Comment_461).
  • When the unit is briked and i can't access the Metaboot mode, how can i upload the old firmware(0.6) ?
  • We will send out steps soon for everyone when we have worked out a system to update and unbrick boards.
  • I have the the firmware 0.8.0 and fortunately the IOS app is able to access the meta wear.   Everything is working for me except the LED light will not turn on and/or flash.

    Would this be a side effect of 0.8.0 as well?  If not, what would cause the LED light to just stop working...especially when the board hasn't been touched and is just laying on my desk in a cool/dry place?
  • Hi Matthew,

    The LED is a known issue with some boards. We used 2 different LED modules in the MetaWears we shipped due to parts availability. Unfortunately, when the 0.8.0 firmware contained some optimizations that contained a bug where one type of the LED modules no longer worked.

    We have fixed this along with a few other bugs and are currently testing it internally. Look for a new firmware update in the next couple of days.

    If you need to reset your board because it is bricked, check this thread for steps: 
    short the reset pin and hold down the push button http://community.mbientlab.com/discussion/comment/461/#Comment_461).
  • Hi,

    Try to update the firmware 0.8.0 to 0.8.6
    With the firmware update app on IOS. Can update to 0.8.6 with the firmware 0.8.0 but cannot reboot after the update.
    I still have access to MetaBoot by pushing the button and plug in the USB, so 
    I downloaded the firmware from releases.mbientlab.com/metaweare. 
    Using iTunes to load the file firmware.0.8.6.hex in nRF Toolbox.
    Select the firmware as an application file in nRF Toolbox DFU app.
    Stop loading at 4%. 


  • Update: I was able to fix my problem with the app 1.2.2 and metaboot option. 0.8.6 is installed.
  • Thanks for sharing Claude.

    For any users that read this, please update to the latest app version before attempting the update to minimize potential known failures.

This discussion has been closed.