Log download issue


I have 9 MetawearR devices that I configure to log accelerometer values at a 50Hz sample rate.

Once the devices are full, I attempt to download the data using the MetawearAPITest app. The download seems to progress fine but once the progress bar reaches 100%, a message showing "clearing log..." is displayed briefly and then the app disconnects from the sensor and I'm left with a screen showing:

Connected to device: [switch in off position]
Connection State: disconnected

This happens for all 9 devices - I have not been able to download and view a single log as yet.

Is there a way I can get my data off these devices? The data in collecting is hard to come by so I need a reliable way to log and download it.



  • I just tried to log and download 1MB (instead of 8MB) and experienced exactly the same issue so it appears log size isn't the issue.
  • Hi Eric, I tried but the MetaBase app crashes and then I don't even have the option to download the log.
  • edited July 2017
    Regarding the MetaBase app:
    • What iOS device and OS are you using?
    • How were you using the app leading up the crash?
      • Can this crash be consistently reproduced?
    • What sensors were you using and how fast were you sampling?

    Do you have better luck using the normal MetaWear app?
  • - iOS10 on iPhone 7
    - After using the log menu to start logging I reopened the app and chose the download menu to start downloading. It then crashed.
       - Yes
    -MetawearR at 50Hz and 12.5Hz.

    No - I noted this in my initial post.
  • I've notified the iOS developer to checkout the issue mentioned in this thread.  In the meantime, do you have an Android or Windows 10 PC you can try using the boards with?
This discussion has been closed.