MetaWear app gyro caped at 125º/s

I have been experimenting with the MetaWear app and I realised that when it plots the gyroscope data, even if you change the rotation range to, say, 250º/s, the plot y range gets updated, but the values still arrive clamped at 125º/s.

It either is that the MetaWear code does not tell the device to update its internal gyroscope setting or that the setting does not have an effect.

As a side note, I realised that the sensor fusion sample app (the one with the rotating cube) works really well (using only acc/gyro data) if you move the sensor slowly, but if you move it quickly, it fails to respond correctly (misses fast rotations). So, it may be related to the problem that the gyroscope does not change its limits using the API.


  • edited July 2017
    Is this only an issue with the Android apps?  Does the gyro work as expected when using the iOS apps?

    Have you tried resetting the board or reflashing the firmware?

    How were you using the board prior to seeing these issues?
  • It is an issue with Android, because I have currently no iOS device I can test with.

    I tried the "update firmware". I don't know if you mean this by "reflashing the firmware". What do you mean by resetting? The devices have been powered off because of battery was depleted, so in a sense, I did reset them.

    It has been an issue that I experienced the first time I installed the sample applications (a few weeks ago). 
  • Turns out that the drop down list is inverted relative to the order of the Range enum.  You can fix it yourself by changing line 109 in the file to be Range.values().length - rangeIndex - 1 or wait for app to be updated.

    The sensor fusion app uses the lowest acc and gyro ranges.   You can increase them to the appropriate values to suite your use case.
This discussion has been closed.