Bluetooth signal not strong enough

Hi, I am trying to connect MetaMotionR to an app made in VS 2017 using C#, (I used as a base the "Start App" tutorial). My problem is that it's not listing my bluetooth devices (It's initializing the bluetooth correctly, it just can't find anything).

On the other hand, if I open your app "MetaBase", everything seems to work fine. I just noticed this on MetaBase: most of the time my device shows up a symbol (wi-fi like) with a red X on it, but in spite of this, the app runs and saves information correctly. And sometimes the symbol changes to a Wi-fi like symbol with blue lines and the red X disappears. Is this normal?

Anyways, I realized I can't connect with Visual Studio when the symbol in MetaBase has a red X. The thing is that I don't know how to control the bluetooth signal intensity. I realized that it only appears with blue lines in two occasions: sometimes at the very beginning when I run the MetaBase app and after stopping a new session. But goes down shortly after this two events.
Is there a way to increase the bluetooth signal by code so that I can visualize my devices when I run the Start App tutorial? Because right now I can't do this unless I force the signal to go up by usign the MetaBase app.


  • You can't control the board until you connect to it first.

    Do you see the same connection / scanning issues when:

    • You use another platform (Android, iOS, Linux) or Win10 PC?
    • Create a new app that just uses the Bluetooth LE Advertising functions to scan for peripherals?
  • edited June 2018

    I ran some tests in different Win10 PC and what I discovered is that actually the code works fine (Start App tutorial). The problem is this:

    • If I run the app for the first time the sensor will show up in my devices list and will let me pair the sensor (everything ok here)
    • Then, if I close my app and run it again the sensor will never show up, unless I force my PC bluetooth to turn off and on again.

    Is this normal or is there a way to avoid this?

  • Did you disconnect from the board before closing the app?

  • TearDown() was missing from my code.

    Thanks for helping me out.

Sign In or Register to comment.