Bolts 1.9 compatibility?

Is there any plan for an update to the iOS SDK that supports Bolts 1.9?

I'm currently using MetaWear 2.10.0 and Parse 1.15.3 (both managed with Cocoapods). If I try to upgrade Parse to the latest version 1.17.1, I get this error:

[!] CocoaPods could not find compatible versions for pod "Bolts/Tasks":
In snapshot (Podfile.lock):
Bolts/Tasks (= 1.8.4, ~> 1.8, ~> 1.8.4)

In Podfile:
MetaWear (= 2.10.0) was resolved to 2.10.0, which depends on
Bolts/Tasks (~> 1.8.4)

Parse (= 1.17.1) was resolved to 1.17.1, which depends on
  Parse/Core (= 1.17.1) was resolved to 1.17.1, which depends on
    Bolts/Tasks (~> 1.9)

It looks like Parse requires the latest Bolts 1.9 but MetaWear does not support it.



  • The 2.X version of the API is deprecated, but we will make maintenance updates like this for the next year. Please try version 2.10.1.


  • Thanks, that worked!

    Is there documentation for the 3.x versions? I'd like to upgrade, if the 2.x versions are deprecated, but the docs on the mbientlab website are for 2.10.

This discussion has been closed.