Javascript SDK Compile error

I am trying to read the data from the sensor via Javascript SDK in Raspberry Pi 3 Model B installed with Raspbian Stretch.
I have followed the steps provided in the documentation in order to install the Javascript SDK and its prerequisites to setup my own MetaHub in Raspberry Pi.
https://github.com/mbientlab/MetaWear-SDK-JavaScript

I am facing multiple compile errors when I try to install Noble and Metawear Javascipt SDK
See one of the error screenshot attached. Please advise how to resolve this issue.

Comments

  • Please post the full install log.

  • Please find attached the logs.
    Log1 - complete setup log
    npm-debug.log - metaweark SDK install log.

    Please verify and provide how to fix the issue and make javascript APIs to work.

  • From the debug log, it looks like your system failed the compile the C++ SDK. You need to check that your system is properly setup to compile C++ code.

    16833 verbose stack Error: metawear@0.1.2 install: `make OPT_FLAGS=-Wno-strict-aliasing -C MetaWear-SDK-Cpp/ -j`
    16833 verbose stack Exit status 2
    16833 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/lib/utils/lifecycle.js:255:16)
    16833 verbose stack     at emitTwo (events.js:106:13)
    16833 verbose stack     at EventEmitter.emit (events.js:191:7)
    16833 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/lib/utils/spawn.js:40:14)
    16833 verbose stack     at emitTwo (events.js:106:13)
    16833 verbose stack     at ChildProcess.emit (events.js:191:7)
    16833 verbose stack     at maybeClose (internal/child_process.js:920:16)
    16833 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:230:5)
    16834 verbose pkgid metawear@0.1.2
    16835 verbose cwd /home/pi/MetaWear-SDK-JavaScript
    16836 error Linux 4.14.34-v7+
    16837 error argv "/usr/bin/node" "/usr/bin/npm" "install"
    16838 error node v6.14.3
    16839 error npm  v3.10.10
    16840 error code ELIFECYCLE
    16841 error metawear@0.1.2 install: `make OPT_FLAGS=-Wno-strict-aliasing -C MetaWear-SDK-Cpp/ -j`
    16841 error Exit status 2
    16842 error Failed at the metawear@0.1.2 install script 'make OPT_FLAGS=-Wno-strict-aliasing -C MetaWear-SDK-Cpp/ -j'.
    
Sign In or Register to comment.