Metabase app crashing on windows

I have purchased 10 MetamotionR sensors and yesterday I was performing a test in a hospital to get orientation of moving objects. The Metabase app was crashing all the time and I tried to install it on different machines, the problem is the same every time. Not all sensors are being read and whenever we tried to start streaming, the app crashed. I also tested an app using the SDK and it also crashed when we start recording the stream. It was really annoying for us because we had to terminate the test which required a lot of time to arrange and to get approvals. We had confidence in mbientlab products but we ended up with disappointment. Can you please advise in this issue and possibly how to solve it?

Comments

  • edited October 8
    • What is the hardware and firmware revision of the boards?
    • What Bluetooth adapter is your windows machines using?
    • MetaBase creates log files, store by default in "$user_dir\Downloads\MetaBase\Log". Post the log of one of the crashes.
    • Can you successfully use the iOS or Android versions of MetaBase?
    • Post relevant code snippets of your app that is also crashing.
      • What is the exception that is thrown when the app crashes?
  • edited October 9

    Thanks Eric for the reply!

    • I used the sensors on Dell Precision 7520 mobile workstation.
    • The Bluetooth adapter is: Intel 9x60 826x 726x 3165 Bluetooth UWD Driver
    • I attached the log files
    • The android app also crashed after starting the logging, I didn't try on iOS
    • Hrm...based on the log files, it looks like the crashes are occurring when you are trying to connect to the board?
    • As you were also building your own app, post the relevant code from the app and what exception was thrown when it crashed.
    • What happens if you uninstall the Dell driver and use the generic Windows 10 drivers?
  • I discovered that one of the sensors that is causing the app to crash. The rest of the 9 sensors are read and paired in the metabase windows app. Whenever i try to add this sensor in the device tab, the app crashes. When I isolate this device far enough, the app works fine with the other sensors.

    What can be the reason for that? and Is there a way to reset this unit?

  • Try using the nRF Connect app to connect to the problem board and read the device information characteristics:
    https://play.google.com/store/apps/details?id=no.nordicsemi.android.mcp&hl=en_US

Sign In or Register to comment.