Unable to connect to MetaMotionR using Samsung T510

edited November 2019 in Requests & Bug Reports

One of our clients has Samsung T510 device running Android 9 , and suddenly after 26.9, she unable to connect to the sensor from the app.

I tried to connect with NRF and got the error below when connecting. i tried to restart the tablet and the BLE services, but still, get the error when connecting to the sensor [we cannot do a hard reset to the sensor] :

Sensor spec:

  • Model: MetaMotion R
  • FW: 1.4.4
  • HR:0.4

I appreciate any help with this phenomenon!


  • Do you have any issues with other Android devices?

    1. we didn't experience this specific problem (unable to connect from NRF to sensor), with other Android devices.
    2. We did experience problems with Lenovo tab4 : data stream from the sensor (quaternion or gravity) is suddenly stopped after some time.
    3. However, we have success with Samsung Tablet T510 with both Android 7.0 Android 8.0, and Silverline Tablet with Android 7.0
  • edited November 2019

    Unfortunately there is a lot of OS differences and variability of BLE support in all the Android devices on the market.
    We just updated our MetaBase App to support the latest Android version but nonetheless, some Android devices (especially older devices or Chinese devices) tend to have BLE support issues (there's not much we can do about this unfortunately).

  • Thanks for your replay.
    In all cases i mentioned we were unable to connect also from the MetaBase App (i should have mentioned that we checked also MetaBase App and NRF). However, the bug occurs with Samsung Android 9.0 which is not an older device or Chinese.
    Do you think that there something else we can do or check on the device level?

  • Nope; just use a different device.

Sign In or Register to comment.