Starter Project does not build in iOS

edited March 6 in Python

Just got my first MetaMotionR and am eager to start working with it. However, when I look at the iOS tutorial on your website, it goes on and on about Windows which is a bit off-putting. Then, the page that is actually about Swift suggests that I can either download the zipped SDK and starter project from GitHub, or clone it using the git command line. Unfortunately, neither option worked.

Downloading the zip is what I tried first, but building fails with the fatal error: Build input file cannot be found: '.../MetaWear/MetaWear-SDK-Cpp/bindings/swift/cbindings.swift'.

Then I tried cloning it using git commands from terminal using the command given on your site:
git clone --recurse-submodules git@github.com:mbientlab/MetaWear-SDK-iOS-macOS-tvOS.git
and got a permissions error: Cloning into 'MetaWear-SDK-iOS-macOS-tvOS'...
git@github.com: Permission denied (publickey).
fatal: Could not read from remote repository.

How do I download a working copy of the SDK and starter project for iOS?

Thank you.

Comments

Sign In or Register to comment.