New CSR 4.0 Bluetooth dongles Not Working

Hello there,

I have just bought 2 new CSR 4.0 bluetooth dongles for my linux system and am having problems with it. I connect it to my computer and my computer sees thedongle where it is outputted when I type:
lsusb or,
bluetoothctl list or,
hcitool dev

However, the problem is that when I try to scan with the device it doesn't find anything. I have tried multiple solutions such as updating bluez, switching dongles, different computers, and much more. To explain the problem in a more clear manner, for example when I do "scan on" in bluetoothctl it says "discovering: on" but nothing shows. However, when I select my computer embedded bluetooth dongle and follow the same steps multiple bluetooth devices show including my 7 metasensors. I am just confused why this could be.

I looked for 2 days for a solution and some people have said that because that this is a cheap fake csr dongle, that it is not compatible with new kernals. However, I doubt that Mbientlab is selling bluetooth dongles that only support old kernals 3.9 or less. Some clarification and suggestions would be must appreciated. Thank you.



  • Did you install the drivers as per our tutorials?

  • edited September 2020

    I mean I have done the following from the tutorials:

    sudo apt install bluetooth bluez blueman
    sudo apt-get update
    sudo apt-get upgrade
    sudo reboot

    I didn't put bluez-utils and pi-bluetooth as this is on my computer but I have also tried it on my rpi but same results.

  • Please install everything (don't leave out utils) and send screenshots

Sign In or Register to comment.