MMR connection problem


I met connection problem with a MMR which hasn't been used for almost one month, after worked perfectly before.

After put it in charge overnight I failed getting connected with MetaBase, I also retried after a soft reset (done according to troubleshooting page) but still no way.

Looking in the forum seems that someone else having the same problem got that battery is bad, is there a way to understand if the battery is really bad? Is there anything else I can try to resume my MMR?

As to MMR tech detail since I can't get connected I can't say hardware & firmware version, I don't know if it can be useful for you but
ID = 04823D, MAC = F8:04:45:A3:D1:19.

The smartphone is A Samsung Galaxy M11 with Anroid 10 (SDK 29) and MetaBase is updated to the last version.

p.s. - I don't have a chance to try with iPhone.

Thanks in advance


  • It doesn't look like battery problem because the device is showing up in the scanner. Can you confirm this?
    Your phone detects the MetaWear but cannot connect to it?

  • Hi Laura,
    thanks for your prompt response.

    Yes, the scanner sees the device, as showed in the attached screenshots.
    Yes, phone detects the device but connection fails

  • Can you reset the board with the button press and the plug in simultaneously (see our troubleshooting guide).
    Can you delete the App and reset the Bluetooth on your Android phone. Then re-download the MetaBase App.
    Let me know what happens when you connect on a new App and a resetted MetaWear.

  • I'm sorry Laura, no way.
    I tried all your suggestions, altough I already did before, but still no connection.
    Anything else I can do?

    p.s. - when you say "reset the bluetooth" what exactely do you mean, turn it off and then on?

  • Yah we see some people have issues with Bluetooth on Android phones and sometimes you can do things in the settings/menu of the phone to help with that. I am not familiar with your device so I can't comment but you can take a look at your phone bluetooth settings to see what you can do.

    Honestly, I know you don't want to hear this but you need to find another device (an iPhone); it would really help. This would at least tell us if the phone or the sensor is the problem.

    One last thing is to keep pressing the button on the sensor (for 5-6 seconds) until it goes into MetaBoot and see if you can connect that way.

  • Hi Laura,

    sorry for late reply but when you posted your comment here was already midnight and I was sleeping :smile:

    First of all now the connection works :sweat_smile:, so what happened?

    Well this morning I noticed my smartphone had an OS update (Samsung released a patch) and when I tried the MMR got connected with MetaBase.

    I don't think the patch fixed it because, before to leave the MMR unused for one month, it used to comunicate, I think the key point is the smartphone has been rebooted (as it normally happens after every os update).
    So next time something like this happen again the first try will be to turn mobile off and on (which actually is rule #1 in every troubleshooting list :smile:).

    As to use an iPhone well I understand your point, I know that, differently from iOS and iPhone, Android is a world full of "flavors" because almost every manifacturer put hands into the OS but this should be mainingly about UI, basic things, like bluetooth, should not be affected (at least I hope so).

    Thanks Laura for your effort and your sincerity.

  • Well I really wanted you to reset your bluetooth settings on your phone and re-download the MetaBase App because some smartphones cache the Bluetooth data of certain devices and then it makes it harder to connect (though in some cases it makes it easier - such as wireless headphones). I bet you that OS update did the reset for us and voila!

  • Hey Laura,

    I am using 6 sensor data streams to collect the human body's movement.

    Here I get some problems with MMR sensor while collecting data. I hope you can help me out~ thanks in advance.


    Sometimes one or two sensors will stop collecting data during the test time. For example log_1.txt sensor_0 will stop obtaining new data after 3379 steps, it will keep x:0.49365234375 all the time while other sensors will keep updating x value. However, log_4.txt shows that all sensors can update the data till the end of the program(resetting the sensor).

    Besides, I am sure the battery(over 50%) is ok and I also keep the sensor moving during the test time.

    Is this a common problem that when we use multiple MMR sensors(>=6sensors) at the same time, there will be some sensors that stop working?

    Could it be a hardware problem or not?


  • Bluetooth is not perfect. It can disconnect at any time and for any reason. You have to build in some auto reconnect intelligence into your scripts.

Sign In or Register to comment.