Reconnecting after a few days: How long until I see the board?

I have been doing some prototyping with the metawear R platform.

I have connected to the board successfully before, but I have left it plugged in to charge for quite a long time and I still cannot see it.

Is the board defective already? It was working properly when I last connected to it a few days ago.

Suppose I plug in the board to charge. How long should I have to wait until I can see the device on bluetooth? I have tried resetting the bluetooth device and I have tried sniffing. 


  • As per the discussion on another page, I have disconnected the battery and connected the device by USB only. After restarting the phone, the device connects. 

    One solution to this problem where the battery discharges completely is to add a hardware switch to disconnect the battery when not active. 
  • bestname,
    Thanks for the feedback and update!
  • edited July 2015
    And now the device does not show up at all. I am powering via computer USB, which worked fine yesterday. Board only, no attachments. Have not added the batter back yet, HW switch or no.

    I cannot get the board to show up at all. Restarted BT, restarted device, nothing at all.

    What is the solution? New metawear device?
  • Hello, I still cannot see the board. Any support? If you are shy you can PM me :)
  • edited August 2015
    Did you try using different devices to connect to it? An Android phone, an iPhone, or a table, or a combination of devices?
    Also did you check if it was in the MetaBoot state?

  • Also did you try to hold down the switch when plugging it into USB.  That will force MetaBoot so you can reflash the MetaWear with the MetaWear Apps.
  • edited August 2015

    I ordered some new boards and again this morning I had trouble connecting to one of them. I am recording accelerometer data with high frequency: I suspect there is some bug in the code keeping it running when I disconnect from the device and that this is draining the battery on the device.

    I was able to see the board again by following directions I found in a youtube video:
    - connect the usb power briefly to the metawear
    - disconnect the usb power
    - immediately reconnect the usb power
    - wait 1hr

    After doing this I was able to see and connect to the device. 

    The first device (on USB power) does not broadcast at all. 
  • bestname,

    We can do board exchanges for free if you want to (just send me an email).

    When you first get your board, they are put in a low power sleep mode (for shipping transportation purposes) and it requires a plug-in + plug-out + plug-in of the usb power to get it out of that sleep mode; this could have been what you were experiencing (the board was simply in low power transport/shipping mode).

    If you set the accelerometer data to log then it will keep doing it until you either reset the board or send it a command to stop logging; this could have very well been draining your battery as you had mentioned and could have tripped it to go into the low power sleep shipping/transport mode.
  • Hi Laura, 

    To clarify: the first board was working fine at first.

    Even now, although I have kept the (new) MW device plugged in by cable almost all day, it is not broadcasting. Perhaps that is because I unplugged it briefly (<30s).

    How can I definitively verify that the device has stopped logging and is in a power saving mode? 
  • To clarify, I currently stop the device in the following way:
    Accelerometer accelCtrllr =(Accelerometer) mwCtrllr.getModuleController(Module.ACCELEROMETER);
    mwCtrllr.close(true); // true if it calls MetaWearController.DeviceCallbacks.disconnected()
  • DIsconnecting immediately after writing a command could result in the command being dropped.  It's possible the stop command was never sent due to closing the connection too quickly.
  • Thanks Eric, I have added a 1s delay.
This discussion has been closed.