MMS logging stops after a few minutes

MMS device / FW 1.6.1 / HW 0.1
MetaBase app on iOS

Setting device to log fusion outputs in MetaBase, starting the recording, then stopping it after 15+ minutes. In 3 attempts have not gotten more than a few minutes of data out before logging stops (no data for last 10+ minutes upon download of log). Battery reads 100% in MetaBase.

Any way to ensure logging will continue until the session is stopped? I am hoping to ultimately run 3-4 hour sessions.

Comments

  • It should continue logging as long as it is in "logging mode" and not "streaming mode". I will see if I can replicate this to see if its a bug.

  • Thank you. Same result using the MetaWear app as well, logging Fusion data.

  • What speed and which sensor fusion? I want to replicate exactly.

  • In MetaBase there is no option for speed, but Qauternion and/or Gravity at 100 Hz.

    In MetaWear NDoF Quat (again no rate option).

  • It seems to be related to fusion. I can stream or log sensor data (accelerometer, gyro) at 100 Hz and it keeps going (at least for ~8-10 minute test time). Any fusion or calculated data like quaternion or gravity stops after ~2-3 minutes. Red LED on the device does continue blinking even after data stops in logging mode.

  • edited April 17

    Thank you very much for that. I will work on this as a bug.

    Please note the bosch sensor fusion (kalman filter) is hardcoded at 100Hz.

  • Are any of the other sensors affected by this bug as far as you're aware? I'd like to settle on the MMS eventually due to the memory size but could get by in the short term with the smaller memory devices as long as they're stable.

  • edited April 20

    No, This isn't an MMS issue since folks not using the App have been able to fill up the MMS log just fine. Seems like it is related to the App only.
    I am working on it.

  • A new firmware version will be released today to fix this. Please update your devices.
    The Android MetaBase App has also been updated and is already available.

  • Android app seems to be working, will lookout for the new FW later.

Sign In or Register to comment.