Problems connecting MMRL to MetaBase for Android

Hello! I am having difficulties to connect MMRL with my Android 10 phone (Redmi Note 7). I have received the sensor before 6 weeks and I have managed to connected it back then and even to make some measures with it. However, I didn't use it for two weeks. I charged it (around 2 hours with AC adaptor) and tried to connect it but with no success (every time with turn on Bluetooth and location of the phone). I have looked at the troubleshooting and followed the instruction but again the same result. Eventually, I made a soft reset of the device and clean install of the app ( several times tried this option) and one of the times I have managed to begin the initial connection but after it and clicking the "done" button it was not listing the device in the device list, so the same effect. I also tried on another Android phone but the same result. Eventually, I have managed to find out an iOS device and there it connected and run perfectly. So, I have managed to update the firmware of the sensor. After that I tried again with the android device (I pre-install again the app in order to sure that is the latest version) but after the initial connection and clicking "done" button, the app stops working ( it closes down immediately after the "done" button). I have even try with "+Device" menu from the app. There I can see the sensor and by clicking to connect, again the app is closing.

Any suggestions?


  • Is the GPS/LOCATION and BLUETOOTH on on your Android device?

  • @Laura said:
    Is the GPS/LOCATION and BLUETOOTH on on your Android device?

    Yes, both of them. I have noted that in the previous text.

  • However, I can see that you have updated the app 2 days ago. With the new update I can connect to the sensor. But now I cannot update the firmware from the app. I am not sure if it is the latest (firmware ver 1.5.1).

  • It is already at the latest firmware.

  • Thank you very much for the fast responses and the good work!

Sign In or Register to comment.