Different behaviour for Sensors and Plattform

edited April 29 in Python

Hi,
I am currently working on connecting several sensors to one raspberry pi and streaming quaternion data to it.
Since, I do not need the full data rate I have used the dataprocessor to only let through a sample every now and then.

I have tested this script on my single MMR sensor and several MMS sensors.

Now the issue: In my virtual machine (Ubuntu 20.04, BlueZ.5.54, metawear 1.0.2, warble 1.2.6) the MMR sensor always works like a charm. The MMS sensors do not work. They do not stream data.

Same code different machine: on the Raspberry Pi 3b (raspbian lite, BlueZ.5.50, metawear 1.0.2, warble 1.2.6) only some of the MMS sensors work. The MMR sensor always does work. It fails as reliable on some sensors as it works on others.

What I have tried so far:
I tried to look at the bluetooth logfiles, but I cannot see any major or concerning differences. (Logfiles: MMR; MMS_w(orking) and MMS_n(ot)w(orking))

Since it works to some degree on the slower Raspberry I tried to slow down the ubuntu machine by adding sleep commands after each command. That didn't change anything.

I made the same script for ACC data to see if it does something to do with sensor fusion. However, the acc script shows the same issue.

Can you see anything obvious in the code? Any rookie mistakes I have made? or do you have any suggestions? or a better way to reduce the samplerate, which is more reliable.

Thanks,
Alex

Sign In or Register to comment.