MMR not connecting to MetaBase App

I went to use my MMR sensor however it was not connecting to the MetaBase App and saying to check the charge and then connect again. I charged it however it was still not connecting. I've had this sensor for a few months and haven't had any problems with it before. I performed the soft reset, deleted the app, and tested the MetaBase app with another MMRL sensor, which worked. Do you have any advice for getting the sensor to connect?


  • Did you follow the troubleshooting steps on the website? Can you report back with more information on what worked and what didn't?
    Also if you have a generic Bluetooth scanner app, does it show the MetaWear advertising?

  • Yes, I have gone through the checklist, I tried deleting the MetaBase App and downloading the latest version, plugging it in, and re-insert the battery to wake it up. This time when I tried to connect the MMR sensor it showed up in the MetaBase app and I was able to add it as a device, however, when I click on the device and enter the "diagnostic" screen it shows that it is scanning and then says "Error, Could not find the device, please check the battery and try again". I made sure that the micro-USB cable is successfully charging another one of my sensors so that doesn't seem to be the issue. I haven't used the battery for very long so I doubt it is expired, however, it is possible that the sensor is over-discharged. Would you recommend using a new battery and if so, should I open up the case to do that?

  • Can you connect to the device again and go ahead and update the firmware?

Sign In or Register to comment.