Debugging BLE Connection issues on Android

edited August 2015 in Android
To connect to the device with Android API version < 21 one must (as I understand) search by UUID. 

On one android device I am able to connect to a metawear by searching for the following UUID: 326A9000-85CB-9195-D9DD-464CFBBAE75A

However, on a different android device, when I run the same program, it does not connect. The device is visible in the MetaWear app. I am using  
mBluetoothAdapter.startLeScan(uMwUuid, mLeScanCallback);

I have tried rebooting and resetting the bluetooth. I am not certain how to proceed. Please advise.

EDIT: 404 get


  • What are the specs for the devices?  Sounds like the second device does not support Bluetooth LE.
  • edited August 2015
    Hi Eric, the second device is a SM-T320. It can connect via the metawear app and for example read the firmware version and print battery life.
  • A simple way is to use USB debugging to view the system logs in Logcat.  Check the status codes of the gatt connection attempts and the visible devices listed from a BLE scan.
This discussion has been closed.