Today we had to cancel research study participants at our University and will keep having to cancel our appointments until we can get the accelerometers working.

We have 6 devices – all are Model MetaMotion R, Model Number 5, Firmware 1.7.2, Hardware 0.4.

We believe that the new firmware update (1.7.2) has made it so that our accelerometers won't work with any devices. They were working yesterday before the update. The devices we typically use with the accelerometers are android cell phones, running with Android Version 9, to access the MetaWear app. We have tried other personal devices, but these are not working either. Once we connect the devices to the phone, we are able to start the recording on the accelerometer as usual (set to data logging, accelerometer on, set to 25Hz, 2g). However, when we try to download the data, the screen shows “Download failed” in red, followed by an error message that reads, “Error - Failed to retrieve logged data from some devices. – Please make sure they are charged and near your Android device, then try again.” The only option available is to select OK, and try again. No matter how many times we run through this process of attempting to download the data, we encounter this same error. Our devices are all charged above 90%, and sitting on top of or near the screen of the phone they are connected to. Once we get this error, the devices seem to be stuck in recording mode. Occasionally, we are able to get out of this recording mode by pressing the “update firmware” button, however, this does not always work and must be repeated several times before the accelerometer exits the recording phase. This method also results in us having to sacrifice the data we collected just to get the device out of recording mode. We have also tried pressing the “Run Diagnostic” button, but nothing happens. We have restarted our devices, re-installed the app, tried new devices – all to no avail.

Is there any way we can revert to the old firmware that was previously installed on the devices? That way we won’t have to cancel more scheduled research study participants this week.

Thanks for your quick help, we really need it!


  • @jepse032

    We identified a firmware issue related to log memory with the model and revision of your devices, and fixed it with firmware release r1.7.3 which is now available. Please let us know if you have any further issues.

    We will follow up with instructions for a firmware downgrade if necessary to get you back up and running.

Sign In or Register to comment.