Unable to get iBeacon working?


I just received my Kickstarter metawear in the mail, and was excited to try the iBeacon functionality that I see in the app.

When I click the button however, nothing happens.
I've tried clicking it, then clicking the Connected/Disconnected toggle
I've tried clicking it, then quitting the app
I've tried clicking it, then disabling bluetooth then re-enabling it

Nothing I do can get the metawear to show up in any of the iBeacon apps I downloaded.

Am I doing something wrong?



  • This is a great question, we'll be sure and clarify this within the app on next release.  For now, here is the answer:

    iBeacon's work by broadcasting a unique identifier (UUID), major value, and minor value.   For an app to find the iBeacon it's required to at least know the UUID to scan for, only major and minor values can be wild carded.

    For this reason, you need to configure an app to search for the MetaWear UUID.  If you use the app called "Locate Beacon", simply tap the "Locate iBeacons" button on the main menu, then tap the table cell that says "Tap here to configure visible iBeacon UUID's".  From there you can hit the + in upper right corner and create iBeacon with the Proximity UUID of "326A9000-85CB-9195-D9DD-464CFBBAE75A".
This discussion has been closed.