UNRESPONSIVE MMR DEVICES

Our lab has 6 devices that we purchased from MBIENTLAB for human clinical studies. All 6 are MetaMotion R, model number 5, Hardware 0.4. Currently, only 4 of them are functioning. We use the devices for their ability to serve as accelerometers and log data in collaboration with the MetaBase app.

After we experienced issues with the firmware version 1.7.2 (all 6 of our devices were unable to retrieve logged data), we were luckily able to update to the newest firmware version 1.7.3 when it was released. Firmware version 1.7.3 has allowed us to use 4 of our 6 devices to their normal capacity. Our typical usage involves the MetaBase app – set to data logging, accelerometer on, set to 25Hz, 2g. Sadly, we have 2 devices that are still not functioning.

These two devices, as far as we can tell, are unresponsive. They cannot be connected to the phones (android cell phones, running Android 9) that we use in partnership with our other devices, their LED light is not influenced by pressing the button or plugging the devices in to charge. The devices are undiscoverable within the MetaBase app even while plugged in. We have already tried all of the troubleshooting tips on the MBIENTLAB website (the app is up to date, we have redownloaded the app, we have isolated the devices from each either to attempt to connect, we have tried different phones that have not interacted with the devices before, the battery of the devices are sufficiently charged, and we have performed a soft reset). We do not see any physical damage, either. We use these devices regularly, and do not have any current issues with the other 4 devices. They all use the same chargers, and have about the same amount of regular use (prior to the 2 bricking out on us). My only shred of hope for these devices is that they are shown in our phones’ bluetooth menu – both devices called “Metaboot”, as compared to our functioning device being called “Metawear” in this menu (screenshot attached to this post). Based on previous posts in this forum (and our own experiences with these devices entering Metaboot), we know that if a device is stuck in Metaboot, you can attempt a firmware update. In the past, this has worked for us to get our devices out of Metaboot. However – because we cannot connect these two devices to the app – we are unable to initiate a firmware update.

Is there anything we can do to salvage these two devices and get them back to their original functional capacity? We would love to be able to get our lab’s entire collection of devices working again to streamline our research abilities.

Thanks very much for the help. We appreciate it.

Comments

  • @organ006 Please download the MetaWear app on one of your mobile devices in addition to MetaBase. There is a toggle switch when scanning that will search for MetaBoot devices and it seems that your devices may be stuck there. The lack of charge LED is the strongest indicator.

    If the devices are fully discharged, holding down the button while plugging in USB may force a corrupted device into MetaBoot.

    What process are you using for a soft reset on the devices?

  • edited June 24

    @Matt

    Thanks for getting back to us so quickly!

    To answer your question -- the soft reset that we have been performing is from the Troubleshooting page on the MBIENTLAB website. It involves plugging the device in while holding down the button, not releasing until completely plugged in.

    After downloading the MetaWear app -- we can see the two devices listed. As we assumed, they are stuck in MetaBoot. When we choose to connect these devices, we get a Warning that the devices are stuck in MetaBoot, with the same tip about initiating a firmware update to return the board to normal. When we select the option to Update Firmware, however, a notice at the bottom of the screen appears stating, "Cannot determine if newer firmware is available for MetaBoot boards". See attached screenshots.

    We also attempted the option from the kebob menu to 'reset' but are given the response "Cannot issue soft reset to MetaBoot board". In this same menu, there is an option to initiate Manual DFU but we did not want to try that without prior guidance. Is that the next step? Or do you have additional tips?

    Thanks so much for all of your help.

Sign In or Register to comment.