MetaBase crashing on start up

I've been using MetaBase successfully for some time.

I attempted to set a logging run going this morning using the Windows App (possible diagnostic – just after installing Windows updates?) logging Euler angles and acceleration.
App crashed (silently closed) while displaying ‘configuring boards’
Following this any attempt to reopen the app leads to it silently crashing, usually within a few (1-3, occasionally up to ~10) seconds. Windows error log files added below this.
Tried installing Andriod app to use MetamotionR device, but it cannot find the device (checked device has battery by charging it up for a bit and trying again, no change)
Tried re-installing MetaBase – no change in behavior

Faulting application name: MetaBase.Uwp.exe, version:, time stamp: 0x5b8bbdb5
Faulting module name: twinapi.appcore.dll, version: 10.0.18362.836, time stamp: 0xc9e8f504
Exception code: 0xc000027b
Fault offset: 0x00000000000d6558
Faulting process id: 0x3ef8
Faulting application start time: 0x01d634d4ddcf7f05
Faulting application path: C:Program FilesWindowsAppsMbientLab.43351ABAF8FB0_2.2.0.0_x64__afn0cdqbtq7jeMetaBase.Uwp.exe
Faulting module path: C:WINDOWSSYSTEM32twinapi.appcore.dll
Report Id: 307ddd6a-62cf-42cd-a656-582734ae2176
Faulting package full name: MbientLab.43351ABAF8FB0_2.2.0.0_x64__afn0cdqbtq7je
Faulting package-relative application ID: App


  • There is not enough information in this post to comment. Please see

  • There is all the information that is available. As MetaBase is crashing I cannot get you any of the following:
    Hardware revision [0.1]
    Firmware revision [1.4.4]
    Model number [5]
    I could provide information about the purchase date which may be informative on this - and did so when I tried to report this directly rather than via the forums.

    Host device: Windows 10 laptop, OS Build 18363.836

    I have provided a clear description of the (repeatable) problem - MetaBase crashes within seconds of opening. No log is produced.

    MetaBase version is

    Last good log was:
    [2020-05-27T15:28:29.869] Configuring 1 devices
    [2020-05-27T15:28:29.870] C775E5EC5136: Initializing device
    [2020-05-27T15:28:32.095] C775E5EC5136: Running Quaternion at 100.000Hz
    [2020-05-27T15:30:45.850] Live stream completed

  • edited June 2020


    1. Delete the MetaBase App
    2. Reinstall your BLE drivers and make sure they fully work (test with the Bluetooth config/setup main screen)
    3. Re-install MetaBase App

    The MetaBase App will crash if there is a problem with your Bluetooth settings.

    If you are using a dongle, re-install the drivers and test them to make sure they work before installing the MetaBase App.

Sign In or Register to comment.