Reliable Communication between MetaHub and MetaMotionR Sensors

Hi there,

I got my MetaHub loaded with the image from the tutorial page and am attempting to reliably log and download data. While I have managed to do it with 4 out of my 8 sensors once, I still often run into issues.


  • I do run 2 bluetooth dongles that were setup according to the turorials page and seem to run okay. For logging this seems to be much less critical as the configuration and download happens 1 by 1 anyway.
  • I then simply adjust the metabase-config.json file (log or download) and let it run

Can somebody help me understand some of the issues that i am running into? I don't have much knowledge of whats happening behind the terminal window. Let me know if there are aditional protocols I can provide to help me better understand the issues.

  1. Could not find device. In one extreme case all 6 sensors could not be found. Usually it is more like 1 or 2 it happens to. In this case I performed a light reset to all sensors and got much better results then. It still happens sometimes though. I assume that low battery or being out of reach are 2 possible problems. With both those eliminated I believe the status of the sensor plays an effect. I assume the sensor unable to "communicate/be configured" while it is (accidentally) logging and does only listen for the download command? What else could be an issue here?

Also happens during downloads

  1. Unknown entry. It happend a couple of times when I tried to download log files from the sensor. While some sensors download fine, others seem to run into issues. What may cause that?

  1. Name issue. This happened during a download and seems to have to do with the sensor name. I did previously name my sensors Meta1 to Meta8 using the ESM Board Admin. I use the same names in the config file. Are the names an issue here or is it more an informative line?

  1. Stuck during logging configuration. Lastly it happened a few times in a row with the same sensor, that the program was stuck at the logging configuration of it. perhaps similar causes as in Issue 1?

I do hope the screenshots I attached for each issue are visible.

All functions seem to work fine sometimes, but I keep running into these issues rather regularly making it currently impossible to relieably retireve a complete set of logging data from a setup with multiple sensors. I am guessing and hoping the issues are on my side and my information provided allows for some assistance,



  • You need to add the dongles to the .json
    Right now, one dongle is doing all the work and it's too many connections at once.

  • Well that would be an easy fix for many problems.
    I could not find any commmands to configure the dongles in the json here or in other threads. Can you advise where to find that and maybe it makes sense to add instructions there or anywhere in the tutorials, unless I missed it,

  • I may not have this enabled in the current metahub. I looked at the code and there is no dongle related inputs. I will have do add this functionality in the future.

  • So is there a way to solve my problems without writing that entire dongle configuration myself (Which I am certainly not capable of)?

  • Hi.
    Should we understand that, even using the "log" / "download" commands, there is still a limited number of 4 sensors that can be connected per on dongle?
    any progress/reply on the issue? We are also about to start data acquisition with 8 sensors (streaming not needed, so we opted for the log option that seems more "stable"), we would be happy if you somehow could give us feedback on the issue you you had raised here and maybe solved.

  • I am having this same issue with one sensor, so I don't think (although I could be wrong) it's the multiple sensors necessarily.

Sign In or Register to comment.