Troubleshooting steps

I picked up a 5-pack of Metawear boards and have to say I am a little frustrated at the sparse documentation.  I've read through the getting started guides and community discussions but there doesn't seem to be any indication of what to do when the boards simply don't respond (To BT scans, button presses, battery charging, etc.).  --It doesn't help that USB is unusable for any kind of debugging or even an indication that the board is live when plugged into USB.

I've tried connecting all 5 (One at a time) to batteries, charging them via USB, trying to get any indication of life from the boards but they don't appear when I scan for BT devices, whether using the Android sample app or the system BT scans.  I've used a Nexus 7 (Running 4.4.4), an iPad Air (7.1.1), and other BT hosts without any sign of the boards when scanning.  I'm unsure whether I got a bad batch or whether I'm missing something because there is no response at all from the boards, whether the batteries and motors are connected or not.  Sure would be nice if the LED would come on when charging or there were other means of indicating the board was active aside from BT...  I'm accustomed to pressing a button to initiate pairing but there's no documentation to indicate how to do this for the Metawear platform.


  • I'm going to reply to myself since the mystery has been resolved.  I have a 2012 Nexus 7, which apparently doesn't support Bluetooth-LE officially (The chipset supports it but requires a custom ROM or root+paid patch to enable it).  My confusion was due to the fact that my Pebble watch supports BLE but doesn't actually require it.  Also the sample MW app for Android gives no indication when scanning or running that BLE is not available.  Not helpful...

    For others who may be in a similar situation at when starting out...  This may seem obvious but you need a recent Android device supporting BLE (And the sample 'droid app or a BLE scanner), or a BLE scanner on a IOS 7.1+ device to be able to see the devices; a scan for BT devices using the built-in BT settings is _not_ the same as a BLE scan!  Since Mbientlab has not released a binary for the IOS sample app (Due no doubt to Apple's tight grip on the app review and release process) the only way to "see" your MW device on IOS without building the sample app is via a free 3rd-party BLE scanner tool such as "LightBlue" (No affiliation with the developer, just know that it works).

    Key takeaways are that the MW devices give zero feedback that they are functional except for the use of a BLE-compatible app.  No LED comes on when charging or at the completion of a charge; the battery level can be seen via Lightblue, not sure about other BLE scanners.  They are also always discoverable via a BLE scan, so it's not necessary to put them in pairing mode to "see" them when scanning.
  • lbattraw;
    Thanks a million for the feedback! We will publish our Apps in the App Store and on Google Play as soon as they are stable so this doesn't happen again.
  • I'm having the same issue but cannot seem to get the board to connect or even be recognized by my Note 3 (which has full BLE support). I tried a BLE scanner app as well as the sample app. The board heats up when the battery is connected, but that's all the feedback I get from the board. Is there a step I'm missing?
  • @PaulC, I sent you an email on troubleshooting steps.

    I will also leave them here for others:
    1. Remove anything you might have soldered to your MetaWear board (no battery, no buzzer...).
    2. Plug in your MetaWear board to power using the micro-USB cable + connector.
    3. Download the BLE scanner App from Nordic: or any other Bluetooth Low Energy apps for your Mobile device. The Apple App Store has about 50 different Scanner Apps.
    4. These Scanner Apps should scan for nearby Bluetooth Low Energy devices and they will find MetaWear. You can even connect to the board using these Apps (though it won't actually trigger anything to happen physically to the board).
    5. If these Bluetooth Low Energy Scanner Apps cannot find your MetaWear board then please send me an email directly at If the board is connectable then it is working
    6. Optional step: Use our sample Android or iOS app (with XCODE or Eclipse) and interact directly with the board. The sample apps will automatically scan and detect MetaWear and you can troubleshoot it by doing things like reading the ambient temperature.
    A few things to note here is that:
    1. You must make sure that your Mobile device is Bluetooth Low Energy compliant.
    2. Devices that require specific advertising packet to be detected by the Bluetooth menu of your Mobile device will NOT work with MetaWear. What this means is that if you have an iPhone and you attempt to scan for a MetaWear device using the native Bluetooth menu, the iPhone will NOT find your MetaWear device.
    3. We will be publishing out Apps on the GooglePlay and AppleApp store very soon so it will be much easier to troubleshoot.
    Hope this helps!
This discussion has been closed.